HTTP Status Code Lookup

Developer Tools
Share:

1xx Informational

100

Continue

The server has received the request headers and the client should proceed to send the request body.

RFC 7231

101

Switching Protocols

The requester has asked the server to switch protocols and the server has agreed to do so.

RFC 7231

102

Processing

A WebDAV request may contain many sub-requests involving file operations.

RFC 2518

103

Early Hints

Used to return some response headers before final HTTP message.

RFC 8297

2xx Success

200

OK

The request has succeeded.

RFC 7231

201

Created

The request has been fulfilled, resulting in the creation of a new resource.

RFC 7231

202

Accepted

The request has been accepted for processing, but processing has not been completed.

RFC 7231

204

No Content

The server has successfully fulfilled the request and there is no additional content to send.

RFC 7231

206

Partial Content

The server is delivering only part of the resource due to a range header sent by the client.

RFC 7233

3xx Redirection

301

Moved Permanently

This and all future requests should be directed to the given URI.

RFC 7231

302

Found

The resource resides temporarily under a different URI.

RFC 7231

304

Not Modified

Indicates that the resource has not been modified since last requested.

RFC 7232

307

Temporary Redirect

The request should be repeated with another URI but future requests should still use the original URI.

RFC 7231

308

Permanent Redirect

The request and all future requests should be repeated using another URI.

RFC 7538

4xx Client Error

400

Bad Request

The server cannot process the request due to a client error (malformed syntax, invalid request message framing, etc.).

RFC 7231

401

Unauthorized

Authentication is required and has failed or has not been provided.

RFC 7235

403

Forbidden

The server understood the request but refuses to authorize it.

RFC 7231

404

Not Found

The requested resource could not be found on the server.

RFC 7231

405

Method Not Allowed

A request method is not supported for the requested resource.

RFC 7231

408

Request Timeout

The server timed out waiting for the request.

RFC 7231

409

Conflict

Indicates that the request could not be processed because of conflict in the current state.

RFC 7231

410

Gone

The resource requested is no longer available and will not be available again.

RFC 7231

413

Content Too Large

The request is larger than the server is willing or able to process.

RFC 7231

414

URI Too Long

The URI provided was too long for the server to process.

RFC 7231

415

Unsupported Media Type

The request entity has a media type the server does not support.

RFC 7231

422

Unprocessable Content

The request was well-formed but was unable to be followed due to semantic errors.

RFC 4918

429

Too Many Requests

The user has sent too many requests in a given amount of time (rate limiting).

RFC 6585

5xx Server Error

500

Internal Server Error

An unexpected condition was encountered by the server.

RFC 7231

501

Not Implemented

The server does not support the functionality required to fulfill the request.

RFC 7231

502

Bad Gateway

The server, while acting as a gateway, received an invalid response from an upstream server.

RFC 7231

503

Service Unavailable

The server is currently unavailable (overloaded or down for maintenance).

RFC 7231

504

Gateway Timeout

The server, while acting as a gateway, did not receive a timely response from an upstream server.

RFC 7231

505

HTTP Version Not Supported

The server does not support the HTTP version used in the request.

RFC 7231

Frequently Asked Questions

HTTP Status Code Lookup is a free online tool that helps you look up any HTTP status code to get its official name, description, and usage guidelines. It runs entirely in your browser — no sign-up or installation required.